記事番号:10218
メール共有オプションでは、アドレス帳連携の設定を行うことで、kintoneのアプリに登録されている顧客情報とメール共有オプション内にあるメールデータを、メールアドレスをキーにして紐づけることができます。
アドレス帳連携の設定後、紐づけが正常に行われていない場合は、以下の【原因】と【対処】を確認してください。
【原因】
・アドレス帳連携の設定がうまくいっていない
・該当のレコードが同期の対象になっていない
【対処】
〇アドレス帳連携の設定を確認し、正しく設定する
メール共有オプションの画面から「歯車>運用管理」の「アドレス帳」画面を開き、設定が正しいか確認してください。
kintoneのアドレス帳アプリ側でフィールドの変更や削除を行った場合、フィールドの関連付けが外れて同期に失敗している可能性があります。
〇同期の対象となるよう、kintoneの該当レコードまたはアドレス帳連携の設定を更新する
メール共有オプションのアドレス帳連携は、同期の対象となっているレコードをAPIで定期的に同期する仕組みです。
同期の対象となるレコードは、レコードの更新日時が、前回レコードを同期した時間(秒は切り捨て)以降のレコードすべてです。
なお、以下の場合は連携を行うkintoneのアドレス帳アプリ内すべてのレコードが同期の対象となります。
・アドレス帳連携の設定を新たに登録した直後
・アドレス帳連携の設定変更画面で「APIトークン」項目以外のいずれかの項目を変更した直後
同期が行われていないメールアドレスがある場合、該当のメールアドレスが登録されているkintoneのアドレス帳アプリのレコードを更新するか、メール共有オプションのアドレス帳連携の設定を更新することで、同期が行われるかご確認ください。
アドレス帳の設定を変更する
補足
kintoneのレコードを更新する場合、登録している内容を変更する必要はありません。
「更新する」ボタンを押すことで「レコードの更新日時」が更新されるため、 次回以降の同期タイミングでアドレス帳同期の対象となります。
注意
メール共有オプション上でメールの送受信を行ったことがないメールアドレスは、アドレス帳連携の同期対象外となります。
同期の対象となるように、【対処】の内容をお試しください。